Thema Datum  Von Nutzer Rating
Antwort
Rot Makro fügt @ in meine Formel ein
05.01.2021 14:03:12 Mielenzio
NotSolved
05.01.2021 14:37:03 Gast26585
NotSolved
05.01.2021 14:39:55 Gast47223
NotSolved
05.01.2021 14:43:45 Gast63582
NotSolved
05.01.2021 14:46:11 ralf_b
NotSolved
05.01.2021 15:31:23 Gast59492
NotSolved

Ansicht des Beitrags:
Von:
Mielenzio
Datum:
05.01.2021 14:03:12
Views:
81
Rating: Antwort:
  Ja
Thema:
Makro fügt @ in meine Formel ein
Das ist meine Makro: 
 
 
 
Sub Formel_runter_kopieren()
'Formel aus L1 runterkopieren
Dim LastRow As Integer      'last row
With Worksheets("Target Data")
Application.ScreenUpdating = False
   'letzte Zeile auffinden:
   LastRow = Cells(Rows.Count, "B").End(xlUp).Row
   'Formel für O und AG runterkopieren:
   Range(.Cells(2, 15), Cells(LastRow, 15)).Formula = "=IFERROR(INDEX(Deal_Stage,MATCH(RC[-13]&EDATE(RC[-14],-1),Deal_ID&Date_Stamp,0)),support!R2C1)"
   .Range(.Cells(2, 20), Cells(LastRow, 20)).Formula = "=N2+S2"
End With
End Sub
 
 
Die Bezeichnungen "Deal_Stage", "Deal_ID", "Date_Stamp" sind Namen/Bezeichnungen für Spalten. Im Moment der Ausführung übernimmt Excel die Formel aber fügt vor den Bezeichnungen Dollar Zeichen ein sodass es so aussieht: =WENNFEHLER(INDEX(Deal_Stage;VERGLEICH(B9&EDATUM(A9;-1);@Deal_ID&@Date_Stamp;0));Support!$A$2)
Dadurch funktioniert die Formel nicht mehr - warum?
 
Danke für Eure Hilfe
Marco

Ihre Antwort
  • Bitte beschreiben Sie Ihr Problem möglichst genau und ausführlich
  • Codeschnipsel am besten über den Code-Button im Text-Editor einfügen
  • Die Angabe der Emailadresse ist freiwillig und wird nur verwendet, um Sie bei Antworten auf Ihren Beitrag zu benachrichtigen
  • Bitte markieren Sie Ihre Anfrage als erledigt wenn Ihnen geholfen wurde
Thema: Name: Email:

 
 

Thema Datum  Von Nutzer Rating
Antwort
Rot Makro fügt @ in meine Formel ein
05.01.2021 14:03:12 Mielenzio
NotSolved
05.01.2021 14:37:03 Gast26585
NotSolved
05.01.2021 14:39:55 Gast47223
NotSolved
05.01.2021 14:43:45 Gast63582
NotSolved
05.01.2021 14:46:11 ralf_b
NotSolved
05.01.2021 15:31:23 Gast59492
NotSolved